VISUALG- Programa para testar a lógica AQUI

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

VISUALG- Programa para testar a lógica AQUI

Mensagem por ADM-Brack em Dom Abr 27, 2008 1:05 am

Este programa serve para você testar os seus algoritmos.
fácil compreensão e bem usual.
você pode baixar no baixaki ele no link abaixo:
http://baixaki.ig.com.br/download/Visualg.htm

usem ele para podermos começar a aprender lógica.

Atenciosamente,
Equipe UG

_________________
Atenciosamente,
Equipe MuLucK e Equipe UG.

ADM-Brack
Admin
Admin

Masculino
Número de Mensagens: 159
Data de inscrição: 09/02/2008

RPG
RPG MuLucK:
5/225  (5/225)

Ver perfil do usuário http://ugdicas.livreforum.com

Voltar ao Topo Ir em baixo

Re: VISUALG- Programa para testar a lógica AQUI

Mensagem por ADM-Brack em Dom Abr 27, 2008 1:08 am

Referências da Linguagem de Programação do VisuAlg

Nesta página estão todas as palavras-chave da linguagem de programação do VisuAlg. Em cada uma delas, há um link para sua correspondente seção dentro das páginas de ajuda.

aleatorio
algoritmo
arquivo
ate
caractere
caso
cronometro
debug
e
eco
enquanto
entao
escolha
escreva
escreval
faca
falso
fimalgoritmo
fimenquanto
fimescolha
fimfuncao
fimpara
fimprocedimento
fimrepita
fimse
funcao
inicio
int
inteiro
interrompa
leia
limpatela
logico
mod
nao
ou
outrocaso
para
passo
pausa
real
procedimento
repita
retorne
se
senao
timer
var
vetor
verdadeiro
xou

_________________
Atenciosamente,
Equipe MuLucK e Equipe UG.

ADM-Brack
Admin
Admin

Masculino
Número de Mensagens: 159
Data de inscrição: 09/02/2008

RPG
RPG MuLucK:
5/225  (5/225)

Ver perfil do usuário http://ugdicas.livreforum.com

Voltar ao Topo Ir em baixo

Re: VISUALG- Programa para testar a lógica AQUI

Mensagem por ADM-Brack em Dom Abr 27, 2008 1:27 am

var
totallata,custolata,altura,raio,areatotal:real
inicio
// Seção de Comandos
escreva(" Qual a altura do tanque? : ")
leia(altura)
escreva(" Qual o raio do tanque? : ")
leia(raio)
areatotal<-(2*3.14)*(raio*altura)+(2*3.14)*(raio^2)
totallata<-(int(areatotal/15)+1)
custolata<-totallata*5
escreval("")
escreval(" Vai precisar de ",totallata," latas de tintas")
escreval(" para pintar todo o cilindro")
escreval("")
escreval(" As ",totallata," Vão custar R$",custolata,",00 reais")
escreval("")
escreval("")
escreval("")


fimalgoritmo





explicações

<- é recebe
= igual
> maior que
< menor que
<= menor ou igual
>= maior ou igual
<> diferente
* Multiplicação
/ divisão
var é variável
variável é um numero que pode variar como a altura do tanque neste programa "altura"
aspas duplas " indicam que é um texto para aparecer no programa

escreva e escrevaL é para escrever algo na tela com L é para pular uma linha

existe varios tipos de variáveis são elas
Inteiro = -2 -1 0 1 2 3 4 5 ...
reais = -1.087 -1 -0.98 1.33 2.43 ....
caractere = " tudo que for escrito"
mais em outros programas existe 2 formar
char = caractere que é apenas uma letra
e string que é o conjunto de letras que nesse caso não iremos usar.

é um pouco .. qualquer coisa tem mais nos tutorias que colocamos para download.

Atenciosamente,
Equipe UG

_________________
Atenciosamente,
Equipe MuLucK e Equipe UG.

ADM-Brack
Admin
Admin

Masculino
Número de Mensagens: 159
Data de inscrição: 09/02/2008

RPG
RPG MuLucK:
5/225  (5/225)

Ver perfil do usuário http://ugdicas.livreforum.com

Voltar ao Topo Ir em baixo

Re: VISUALG- Programa para testar a lógica AQUI

Mensagem por GM-Maconha em Qua Maio 14, 2008 11:56 am

uia brack Shocked

tava inspirado é? =P

muito bom o tutorial... foi voce quem fex? se não cade os creditos? não queremos um forum sem organização ne???


by: Maconha
Cool

GM-Maconha
Iniciante
Iniciante

Masculino
Número de Mensagens: 11
Idade: 33
Localização: em casa
Qual Sua Classe no MuLuck?: Soul-Master
Data de inscrição: 13/04/2008

RPG
RPG MuLucK:
1/1  (1/1)

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: VISUALG- Programa para testar a lógica AQUI

Mensagem por ADM-Brack em Ter Maio 20, 2008 9:47 pm

esse tutorial fui eu mesmo que fiz ^^ as referencias é do programa.. agora o terceiro tópico foi eu que fix =x

_________________
Atenciosamente,
Equipe MuLucK e Equipe UG.

ADM-Brack
Admin
Admin

Masculino
Número de Mensagens: 159
Data de inscrição: 09/02/2008

RPG
RPG MuLucK:
5/225  (5/225)

Ver perfil do usuário http://ugdicas.livreforum.com

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

Permissão deste fórum:
Você não pode responder aos tópicos neste fórum