Exercicio 1 de Lógica

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Exercicio 1 de Lógica

Mensagem por ADM-Brack em Sab Abr 26, 2008 7:06 pm

Algoritmos - Exercício de Aprendizagem nº1

Escreva um algoritmo, em português estruturado, para cada uma das questões abaixo.

1. Leia um número e exiba seu sucessor.

2. Calcular a média final (usando a ponderação da FASETE) dadas às notas das 3 provas e produzir uma saída com a média e a situação do aluno de acordo com o seguinte critério:
1. Média >= 7, aprovado;
2. 5 < média < 7, recuperação;
3. Média < 5, reprovado.

3. Calcular a quantidade dinheiro gasta por um fumante. Dados: o número de anos que ele fuma, o nº de cigarros fumados por dia e o preço de uma carteira.

4. Ler dois números inteiros, x e y, e imprimir o quociente e o resto da divisão inteira entre eles.

5. Para ler dois valores reais do teclado, calcular e imprimir na tela:
a) A soma destes valores; b) O produto deles; c) O quociente entre eles

6. Para ler 3 números reais do teclado e verificar se o primeiro é maior que a soma dos outros dois.

7. Ler um nome do teclado e ver se é igual ao seu nome. Imprimir conforme o caso: “NOME CORRETO” ou “NOME INCORRETO”.

8. Que gere o preço de um carro ao consumidor e os valores pagos pelo imposto e pelo lucro do distribuidor, sabendo o custo de fábrica do carro e que são pagos: a) de imposto: 45% sobre o custo do carro; b) de lucro do distribuidor: 12% sobre o custo do carro.

9. Leia a velocidade máxima permitida em uma avenida e a velocidade com que o motorista estava dirigindo nela e calcule a multa que uma pessoa vai receber, sabendo que são pagos: a) 50 reais se o motorista ultrapassar em até 10km/h a velocidade permitida (ex.: velocidade máxima: 50km/h; motorista a 60km/h ou a 56km/h); b) 100 reais, se o motorista ultrapassar de 11 a 30 km/h a velocidade permitida. c) 200 reais, se estiver acima de 31km/h da velocidade permitida.

10. Ler 2 números inteiros do teclado. Se o segundo for diferente de zero, calcular e imprimir o quociente do primeiro pelo segundo. Caso contrário, imprimir a mensagem: “DIVISÃO POR ZERO”.

_________________
Atenciosamente,
Equipe MuLucK e Equipe UG.
avatar
ADM-Brack
Admin
Admin

Masculino
Número de Mensagens : 159
Data de inscrição : 08/02/2008

RPG
RPG MuLucK:
5/225  (5/225)

Ver perfil do usuário http://ugdicas.livreforum.com

Voltar ao Topo Ir em baixo

Re: Exercicio 1 de Lógica

Mensagem por ADM-Brack em Sab Abr 26, 2008 7:07 pm

Resolvam esses exercícios se tiverem duvida postem que eu mostro como fazer

_________________
Atenciosamente,
Equipe MuLucK e Equipe UG.
avatar
ADM-Brack
Admin
Admin

Masculino
Número de Mensagens : 159
Data de inscrição : 08/02/2008

RPG
RPG MuLucK:
5/225  (5/225)

Ver perfil do usuário http://ugdicas.livreforum.com

Voltar ao Topo Ir em baixo

Re: Exercicio 1 de Lógica

Mensagem por Andrus em Seg Jun 09, 2008 12:27 pm

ADM-Brack escreveu:Resolvam esses exercícios se tiverem duvida postem que eu mostro como fazer
Caro amigo, ainda to iniciando meus estudos em logica, bem no inicio mesmo, gostaria, se possivel, ver as respostas desses exercicios, grato pela força.

Andrus
Iniciante
Iniciante

Masculino
Número de Mensagens : 1
Idade : 51
Localização : Recife
Data de inscrição : 09/06/2008

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Exercicio 1 de Lógica

Mensagem por ADM-Brack em Qua Jun 11, 2008 12:02 pm

Segunda questão

algoritmo "semnome"
// Função :
// Autor :
// Data : 13/4/2008
// Seção de Declarações
var
nota1,nota2,nota3,media:real
inicio
// Seção de Comandos
escreva("digite a primeira nota:"," ")
leia(nota1)
escreva("digite a segunda nota:"," ")
leia(nota2)
escreva("digite a terceira nota:"," ")
leia(nota3)
media<-(nota1+nota2+nota3)/3
se(media>=7) entao
escreva(" Parabens voce foi aprovado com media:",media)
senao
se(media>5) e (media<7) entao
escreva (" Estude mais voce foi para recuperarcao com media:",media)
senao
se(media<5)entao
escreva ( "sinto muito voce foi reprovado com media :",media)
fimse
fimse
fimse
fimalgoritmo

_________________
Atenciosamente,
Equipe MuLucK e Equipe UG.
avatar
ADM-Brack
Admin
Admin

Masculino
Número de Mensagens : 159
Data de inscrição : 08/02/2008

RPG
RPG MuLucK:
5/225  (5/225)

Ver perfil do usuário http://ugdicas.livreforum.com

Voltar ao Topo Ir em baixo

Re: Exercicio 1 de Lógica

Mensagem por ADM-Brack em Qua Jun 11, 2008 12:03 pm

terceira questão


algoritmo "semnome"
// Função :
// Autor :
// Data : 13/4/2008
// Seção de Declarações
var
total,anos,cigarrosdia,carteira:real
inicio
// Seção de Comandos
escreva("Quantos anos voce fuma ?")
leia(anos)
escreva("Quantos Cigarros voce fuma por dia ?")
leia(cigarrosdia)
escreva("qual o preco da carteira de cigarro ?")
leia(carteira)
anos<-anos*365.25
total<-((cigarrosdia/20)*carteira)*anos)
escreva("Total Gasto com cigarro foi:","R$",total)



fimalgoritmo

_________________
Atenciosamente,
Equipe MuLucK e Equipe UG.
avatar
ADM-Brack
Admin
Admin

Masculino
Número de Mensagens : 159
Data de inscrição : 08/02/2008

RPG
RPG MuLucK:
5/225  (5/225)

Ver perfil do usuário http://ugdicas.livreforum.com

Voltar ao Topo Ir em baixo

Re: Exercicio 1 de Lógica

Mensagem por ADM-Brack em Qua Jun 11, 2008 12:04 pm

quarta questão

algoritmo "semnome"
// Função :
// Autor :
// Data : 13/4/2008
// Seção de Declarações
var
valor1,valor2,resultado,resto:inteiro
inicio
// Seção de Comandos
escreva("digite um valor para dividir:"," ")
leia(valor1)
escreva(valor1,"/")
leia(valor2)
resto<-(valor1%valor2)
resultado<-valor1\valor2
se (valor2=0) entao
escreva("impossivel de dividir")
senao
escreva ("o quociente eh",resultado,". o resto eh",resto)
fimse
fimalgoritmo

_________________
Atenciosamente,
Equipe MuLucK e Equipe UG.
avatar
ADM-Brack
Admin
Admin

Masculino
Número de Mensagens : 159
Data de inscrição : 08/02/2008

RPG
RPG MuLucK:
5/225  (5/225)

Ver perfil do usuário http://ugdicas.livreforum.com

Voltar ao Topo Ir em baixo

Re: Exercicio 1 de Lógica

Mensagem por ADM-Brack em Qua Jun 11, 2008 12:04 pm

10ª

algoritmo "semnome"
// Função :
// Autor :
// Data : 14/4/2008
// Seção de Declarações
var
dividendo,divisor,quociente:inteiro
inicio
// Seção de Comandos
escreva("digite um valor para ser o dividendo: ")
leia(dividendo)
escreva("digite um valor para ser o divisor: ")
leia(divisor)
quociente<-dividendo\divisor
se divisor=0 entao
escreva(" Divisão por zero")
senao
escreval(" O quociente do primeiro pelo segundo é : ",quociente)
fimse

fimalgoritmo

_________________
Atenciosamente,
Equipe MuLucK e Equipe UG.
avatar
ADM-Brack
Admin
Admin

Masculino
Número de Mensagens : 159
Data de inscrição : 08/02/2008

RPG
RPG MuLucK:
5/225  (5/225)

Ver perfil do usuário http://ugdicas.livreforum.com

Voltar ao Topo Ir em baixo

Re: Exercicio 1 de Lógica

Mensagem por ADM-Brack em Qua Jun 11, 2008 12:05 pm

algoritmo "semnome"
// Função :
// Autor :
// Data : 14/4/2008
// Seção de Declarações
var
valor1,valor2,valor3,soma:real
inicio
// Seção de Comandos
escreva("digite o primeiro valor:")
leia (valor1)
escreva("digite o segundo valor:")
leia (valor2)
escreva("digite o terceiro valor:")
leia (valor3)
soma<-valor2+valor3
se (valor1>valor2+valor3) entao
escreval("o ",valor1," e maior que",valor2," +",valor3," =",soma)
senao
escreva("o primeiro valor",valor1," é menor que a soma dos outros 2:",valor2," +",valor3," =",soma)
fimse
fimalgoritmo

_________________
Atenciosamente,
Equipe MuLucK e Equipe UG.
avatar
ADM-Brack
Admin
Admin

Masculino
Número de Mensagens : 159
Data de inscrição : 08/02/2008

RPG
RPG MuLucK:
5/225  (5/225)

Ver perfil do usuário http://ugdicas.livreforum.com

Voltar ao Topo Ir em baixo

Re: Exercicio 1 de Lógica

Mensagem por ADM-Brack em Qua Jun 11, 2008 12:05 pm

algoritmo "semnome"
// Função :
// Autor :
// Data : 14/4/2008
// Seção de Declarações
var
custof,impostos,lucrod,total:real
inicio
// Seção de Comandos
escreva("digite o custo de fábricação do carro: ")
leia(custof)
impostos<-custof*45/100
lucrod<-custof*12/100
total<-custof+lucrod+impostos
escreval("")
escreval(" O preço final para o consumidor é : ",total)
escreval(" Os impostos sobre o produto foram : ",impostos)
escreval(" Os lucros do distribuidor foram : ",lucrod)

fimalgoritmo

_________________
Atenciosamente,
Equipe MuLucK e Equipe UG.
avatar
ADM-Brack
Admin
Admin

Masculino
Número de Mensagens : 159
Data de inscrição : 08/02/2008

RPG
RPG MuLucK:
5/225  (5/225)

Ver perfil do usuário http://ugdicas.livreforum.com

Voltar ao Topo Ir em baixo

Re: Exercicio 1 de Lógica

Mensagem por ADM-Brack em Qua Jun 11, 2008 12:07 pm

não responde todos mais com estes exemplo espero que você conclua todos exercicios .
se não conseguir é só perguntar e se não conseguir fazer eu ponho as respostas =x

_________________
Atenciosamente,
Equipe MuLucK e Equipe UG.
avatar
ADM-Brack
Admin
Admin

Masculino
Número de Mensagens : 159
Data de inscrição : 08/02/2008

RPG
RPG MuLucK:
5/225  (5/225)

Ver perfil do usuário http://ugdicas.livreforum.com

Voltar ao Topo Ir em baixo

Re: Exercicio 1 de Lógica

Mensagem por Conteúdo patrocinado


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum